Bugs? Problems? Report them here!

Introductions, Rules, Announcements, and Feedback
User avatar
bystander
Apathetic Retiree
Posts: 16209
Joined: Mon Aug 28, 2006 2:06 pm
Location: Oklahoma

Re: Bugs? Problems? Report them here!

Postby bystander » Wed Jan 04, 2017 4:41 am

Chris Peterson wrote:When you go to the main APOD page for a day, you see the page contents but not the image? Or you're not seeing the image thumbnails in the Asterisk forum?

APOD main page. The page comes up. I can see everything but the image. All the links are there and work, but there isn't any image. It's like it just ignores the whole section between the date and the title, no image, no click-thru.
Know the quiet place within your heart and touch the rainbow of possibility; be
alive to the gentle breeze of communication, and please stop being such a jerk.
— Garrison Keillor

hartacus
Asternaut
Posts: 1
Joined: Wed Jan 11, 2017 2:44 am

Re: Bugs? Problems? Report them here!

Postby hartacus » Wed Jan 11, 2017 3:01 am

geckzilla wrote:APOD is coming through https (secure socket) only now and it has broken a lot of things.


It seems that the Random APOD Generator (https://apod.nasa.gov/apod/random_apod.html) is one of the broken things. Seems to be not working since about that time.

In the script's line:
var final_html = '<iframe src="http://apod.nasa.gov/apod/ap'+random_year+random_month+random_day+'.html" id="apod"></iframe>';
Replacing the http with https seems to work in firefox's inspector at least

User avatar
geckzilla
Ocular Digitator
Posts: 8607
Joined: Wed Sep 12, 2007 12:42 pm
Location: Modesto, CA

Re: Bugs? Problems? Report them here!

Postby geckzilla » Wed Jan 11, 2017 4:21 am

hartacus wrote:
geckzilla wrote:APOD is coming through https (secure socket) only now and it has broken a lot of things.


It seems that the Random APOD Generator (https://apod.nasa.gov/apod/random_apod.html) is one of the broken things. Seems to be not working since about that time.

In the script's line:
var final_html = '<iframe src="http://apod.nasa.gov/apod/ap'+random_year+random_month+random_day+'.html" id="apod"></iframe>';
Replacing the http with https seems to work in firefox's inspector at least

Thanks. This was discovered a few days ago, but the person who has access to fix it has been out. Hopefully it gets fixed soon.
Just call me "geck" because "zilla" is like a last name.

Stanley Allen

Re: Bugs? Problems? Report them here!

Postby Stanley Allen » Thu Jan 19, 2017 5:21 pm

geckzilla wrote:APOD is coming through https (secure socket) only now and it has broken a lot of things.


It looks like the RSS feed is broken also. I was subscribed through https://apod.nasa.gov/apod.rss until the Christmas break. Now it doesn't appear to work.

User avatar
rstevenson
Quis custodiet ipsos custodes?
Posts: 2427
Joined: Fri Mar 28, 2008 1:24 pm
Location: Dartmouth, NS, Canada

Re: Bugs? Problems? Report them here!

Postby rstevenson » Fri Feb 10, 2017 2:54 pm

Yay! The thumbnail image (here at the Asterisk, on the daily APOD page) is back!

Rob

User avatar
geckzilla
Ocular Digitator
Posts: 8607
Joined: Wed Sep 12, 2007 12:42 pm
Location: Modesto, CA

Re: Bugs? Problems? Report them here!

Postby geckzilla » Fri Feb 10, 2017 3:16 pm

I had to go and edit each one back in
Just call me "geck" because "zilla" is like a last name.

User avatar
rstevenson
Quis custodiet ipsos custodes?
Posts: 2427
Joined: Fri Mar 28, 2008 1:24 pm
Location: Dartmouth, NS, Canada

Re: Bugs? Problems? Report them here!

Postby rstevenson » Fri Feb 10, 2017 3:30 pm

** pat on back ** (non-ironic)

Rob

alexaa

Re: Bugs? Problems? Report them here!

Postby alexaa » Sun Mar 12, 2017 12:20 pm

Hi, I have an issue with the RSS feed in that I end up with duplicate entries in my RSS reader (thunderbird). I'm sure this is because today's picture in the RSS has the URL https://apod.nasa.gov/apod/astropix.html but tomorrow it will update the URL in the RSS to its direct URL e.g. https://apod.nasa.gov/apod/ap170312.html so my reader downloads the entry again and I end up with two in the list for all entries.

Is it possible to change the RSS so the feed will always use the direct URL e.g. ap170312.html and never the astropix.html URL?

Many thanks,
Alex

Brig

Re: Bugs? Problems? Report them here!

Postby Brig » Thu Mar 30, 2017 7:59 pm

The RSS feed appears to be out of date with the main APOD page. It hasn't been updated in a while.

User avatar
geckzilla
Ocular Digitator
Posts: 8607
Joined: Wed Sep 12, 2007 12:42 pm
Location: Modesto, CA

Re: Bugs? Problems? Report them here!

Postby geckzilla » Fri Mar 31, 2017 12:26 am

I created an alternate RSS feed and it can be found here:
apod_rss.php

Let me know if it works for you.
Just call me "geck" because "zilla" is like a last name.


Return to “Starship Asterisk: Handbook”

Who is online

Users browsing this forum: CommonCrawl [Bot] and 2 guests