Bugs? Problems? Report them here!

Introductions, Rules, Announcements, and Feedback
Nereid
Intrepidus Dux Emeritus
Posts: 832
Joined: Fri Sep 29, 2006 2:01 am

Bugs? Problems? Report them here!

Postby Nereid » Tue Nov 20, 2007 1:59 pm

However, if you see spam, or a rule violation, please send owlice, geckzilla, and/or bystander (the mods) a private message, or report it using the report button.

Once bugs, problems, etc have been resolved, the posts reporting them will be moved to the Resolved problems, bugs etc thread.
Last edited by Nereid on Thu Oct 30, 2008 6:21 pm, edited 2 times in total.

apodman
Teapot Fancier (MIA)
Posts: 1171
Joined: Wed Aug 15, 2007 6:48 pm
Location: 39°N 77°W

Reporting Spam

Postby apodman » Sat Mar 28, 2009 7:57 pm

Anyone who sees spamming activity can use one of the PM links to send a private message to the moderators.

Click on a moderator name, click on the "Send private message" link, add other moderator names, and send.

This is the preferred and most effective action.

The moderators are: owlice, geckzilla, and bystander.

User avatar
Chris Peterson
Abominable Snowman
Posts: 13345
Joined: Wed Jan 31, 2007 11:13 pm
Location: Guffey, Colorado, USA

Re: Bugs? Problems? Report them here!

Postby Chris Peterson » Mon Mar 28, 2011 7:21 pm

Once again, I'd ask the editors to seriously consider not embedding video into the APOD page. It obviously causes no end of difficulty and confusion, problems with incompatible third-party software (not the fault of the editors, of course, but it nevertheless ends up reflecting on the site), browser and codec problems, and long term compatibility issues.

My suggestion would be to always make the APOD a picture, meaning a static image. If that image is clipped from a video, the video source can be provided as a link. This also makes it easy to maintain APOD as a long term archive. When I go back to old APODs, there may be broken links, but the main image is always there since it is locally hosted. I have no confidence at all that embedded links to YouTube or Vimeo are going to work a few years from now (or even a few weeks in some cases).
Chris

*****************************************
Chris L Peterson
Cloudbait Observatory
http://www.cloudbait.com

codenamelegion
Asternaut
Posts: 3
Joined: Mon Nov 07, 2011 9:37 pm

Re: Bugs? Problems? Report them here!

Postby codenamelegion » Mon Dec 12, 2011 12:36 am

The RSS feed currently has non-utf-8 characters yet is declaring itself encoded as utf-8.

Here is the problematic entity (December 07 APOD item):

"It�s the closest match to Earth that has yet been found."

User avatar
ThePiper
Ensign
Posts: 51
Joined: Wed Mar 16, 2011 10:16 am
Location: Swiss

Measurement units @NASA

Postby ThePiper » Sat Jan 14, 2012 8:57 pm

.
Thank you, APOD, to use the metric System (e.g. yesterday, Saturn's Iapetus: Painted Moon).

Unfortunately this is a rare exception in the great world of NASA, its Websites, presentations, documents etc.
Nasa is proclaiming a new era but apparently its system of units stay in the Middle Ages.

http://de.wikipedia.org/w/index.php?title=Datei:English_length_units_graph.svg&filetimestamp=20100719181837

Time to exhort the boss, Charles Bolden: There are not only budget problems...! :blah:

:wink:
.

codenamelegion
Asternaut
Posts: 3
Joined: Mon Nov 07, 2011 9:37 pm

Re: Bugs? Problems? Report them here!

Postby codenamelegion » Wed May 02, 2012 9:42 pm

The Apod RSS feed (http://apod.nasa.gov/apod.rss) has non UTF-8 characters, yet is declaring itself as UTF-8.

The character in question is as follows on line 26:

"Aurora Over Raufarh�fn "

There are also a lot of non-escaped character data (CDATA) entries.

Thanks for your attention.

-Scott

User avatar
Beyond
500 Gigaderps
Posts: 6889
Joined: Tue Aug 04, 2009 11:09 am
Location: BEYONDER LAND

Re: Bugs? Problems? Report them here!

Postby Beyond » Wed Jun 27, 2012 4:23 pm

As of right now, the Asterisk* computer keeps logging me out, even when I'm still here! I deleted the board cookies, and don't have a problem anywhere else.
Now that I'v posted this, I'll leave and come back. If I'm once again logged out, I'll leave this post. If I'm still logged in, I'll delete it.

EDIT: It's now 12 hours later. I found out your cookies don't have a compact privacy policy. I had turned up my privacy setting one notch to block something else, but later when i came here, it started to cause me to be signed out, sometimes during my visit, but always when i left. Oh-well.
To find the Truth, you must go Beyond.

User avatar
ThePiper
Ensign
Posts: 51
Joined: Wed Mar 16, 2011 10:16 am
Location: Swiss

Wanted: Where is APOD ??

Postby ThePiper » Sun Jul 01, 2012 6:48 am

Since two days I have no more access to APOD (http://antwrp.gsfc.nasa.gov/apod/). Does anybody know what happened with the site? NASAs Budget? :?: :?:
The worst scientific finding of mankind: "Everything points to eternal darkness being the ultimate fate of the Universe. Sorry about that." (cit. Chris L Peterson, APOD)

User avatar
geckzilla
Ocular Digitator
Posts: 8674
Joined: Wed Sep 12, 2007 12:42 pm
Location: Modesto, CA

Re: Wanted: Where is APOD ??

Postby geckzilla » Sun Jul 01, 2012 6:54 am

ThePiper wrote:Since two days I have no more access to APOD (http://antwrp.gsfc.nasa.gov/apod/). Does anybody know what happened with the site? NASAs Budget? :?: :?:


No juice.
viewtopic.php?f=9&t=28996
Just call me "geck" because "zilla" is like a last name.

User avatar
ThePiper
Ensign
Posts: 51
Joined: Wed Mar 16, 2011 10:16 am
Location: Swiss

Re: Bugs? Problems? Report them here!

Postby ThePiper » Sun Jul 01, 2012 7:27 am

Thanks, geckzilla. If we would have a Magnetar whirling behind the moon, our energy problems would be solved for the next millions of years... :wink:
The worst scientific finding of mankind: "Everything points to eternal darkness being the ultimate fate of the Universe. Sorry about that." (cit. Chris L Peterson, APOD)

neptunium

Re: Bugs? Problems? Report them here!

Postby neptunium » Tue Jul 10, 2012 4:56 am

Here's a problem: whenever I try to preview a post I make a message saying "The forum you selected does not exist" comes up. Can this be fixed?

User avatar
bystander
Apathetic Retiree
Posts: 16430
Joined: Mon Aug 28, 2006 2:06 pm
Location: Oklahoma

Re: Bugs? Problems? Report them here!

Postby bystander » Tue Jul 10, 2012 6:11 am

neptunium wrote:Here's a problem: whenever I try to preview a post I make a message saying "The forum you selected does not exist" comes up. Can this be fixed?

I can not duplicate your problem. Could you provide more information or maybe some screen prints?
Know the quiet place within your heart and touch the rainbow of possibility; be
alive to the gentle breeze of communication, and please stop being such a jerk.
— Garrison Keillor

RayM
Ensign
Posts: 10
Joined: Thu Jan 12, 2012 4:04 pm

Re: Bugs? Problems? Report them here!

Postby RayM » Tue Jul 10, 2012 11:54 am

I know this has been answered before, but I'm unable to find it in the forum.

Whenever APOD contains an embedded video, the one that displays is not the one in the page source, but rather is one from months ago (currently I'm stuck on an aurora from last January). It's very strange, since the HTML source clearly points to a YouTube video...

Oh, and I'm using Firefox. I've tried clearing history and cookies, but so far with no success.

Help and advice would be much appreciated.

User avatar
geckzilla
Ocular Digitator
Posts: 8674
Joined: Wed Sep 12, 2007 12:42 pm
Location: Modesto, CA

Re: Bugs? Problems? Report them here!

Postby geckzilla » Tue Jul 10, 2012 11:59 am

Ray, what happens if you view it in a different browser? The same thing?
Just call me "geck" because "zilla" is like a last name.

RayM
Ensign
Posts: 10
Joined: Thu Jan 12, 2012 4:04 pm

Re: Bugs? Problems? Report them here!

Postby RayM » Tue Jul 10, 2012 12:29 pm

No - it's fine. But then I normally use Firefox, and this appears to be something 'getting stuck'.

Oh... now here's something interesting: I just opened a new tab in Firefox, and from there the correct video is displayed! If I go back to my original tab and refresh it, though, the old video still displays. How bizarre.

User avatar
geckzilla
Ocular Digitator
Posts: 8674
Joined: Wed Sep 12, 2007 12:42 pm
Location: Modesto, CA

Re: Bugs? Problems? Report them here!

Postby geckzilla » Tue Jul 10, 2012 12:39 pm

Yeah, I'm really not sure. If it only happens in Firefox then it may have something to do with a plugin you may have installed. Or it could be some kind of rare bug?
Just call me "geck" because "zilla" is like a last name.

RayM
Ensign
Posts: 10
Joined: Thu Jan 12, 2012 4:04 pm

Re: Bugs? Problems? Report them here!

Postby RayM » Tue Jul 10, 2012 1:11 pm

Well, I can't say whether or not it only happens in Firefox, since that is the only browser I use to view APOD regularly.

In any case, thanks for your thoughts...

neptunium

Re: Bugs? Problems? Report them here!

Postby neptunium » Wed Jul 11, 2012 8:14 pm

bystander wrote:
neptunium wrote:Here's a problem: whenever I try to preview a post I make a message saying "The forum you selected does not exist" comes up. Can this be fixed?

I can not duplicate your problem. Could you provide more information or maybe some screen prints?

Actually, I found out that this only happens on my mobile phone, but the url for the preview should still be the same, shouldn't it

User avatar
bystander
Apathetic Retiree
Posts: 16430
Joined: Mon Aug 28, 2006 2:06 pm
Location: Oklahoma

Re: Bugs? Problems? Report them here!

Postby bystander » Wed Jul 11, 2012 8:58 pm

neptunium wrote:Actually, I found out that this only happens on my mobile phone, but the url for the preview should still be the same, shouldn't it

I suspect the problem is in the interface of phpBB (the forum sofware) and your mobile browser.

geckzilla, is there a mobile style available? Perhaps that might solve the problem.
Know the quiet place within your heart and touch the rainbow of possibility; be
alive to the gentle breeze of communication, and please stop being such a jerk.
— Garrison Keillor

User avatar
geckzilla
Ocular Digitator
Posts: 8674
Joined: Wed Sep 12, 2007 12:42 pm
Location: Modesto, CA

Re: Bugs? Problems? Report them here!

Postby geckzilla » Wed Jul 11, 2012 9:47 pm

There have more mobile-friendly been styles and mods for phpbb3 for a while now. I used to have one installed for RJN but I eventually disabled it because I was scared of it being a security issue since it was unofficial. And, from what I understand, even though mobile devices are more popular than ever (and ever increasing) there are no plans to release an official mobile-friendly version because the direction for the technology is to ensure that the mobile devices correctly display CSS on their own rather than tailoring CSS and websites for individual devices. That is as it should be because there are a lot of devices with a growing number of device OSes and browsers running on them! It's always been a ludicrous notion that web developers should develop per device rather than devices and their browsers following standards. IE and its lack of adherence is the classic example of this design headache.
Just call me "geck" because "zilla" is like a last name.

User avatar
rstevenson
Quis custodiet ipsos custodes?
Posts: 2457
Joined: Fri Mar 28, 2008 1:24 pm
Location: Dartmouth, NS, Canada

Re: Bugs? Problems? Report them here!

Postby rstevenson » Thu Jul 12, 2012 1:31 am

Three cheers for the voice of reason. Develop for standards, not devices!

Speaking of standards, have you looked at the code in the APOD page lately? :mrgreen:

Rob

ekaim
Ensign
Posts: 13
Joined: Fri Aug 17, 2012 1:14 am

Re: Bugs? Problems? Report them here!

Postby ekaim » Fri Aug 17, 2012 2:01 pm

I just downloaded the latest software for automatic updates of APOD as wallpaper for Windows 7. I used to have an earlier version (pre-Win 7) and am delighted I found that the current software supports Win 7. But the image I'm now getting does not include the explanation I used to get with the old version. Is that no longer included, or is there some way I can get it with the new version?

User avatar
geckzilla
Ocular Digitator
Posts: 8674
Joined: Wed Sep 12, 2007 12:42 pm
Location: Modesto, CA

Re: Bugs? Problems? Report them here!

Postby geckzilla » Fri Aug 17, 2012 3:35 pm

Ekaim, that software was created by an individual not associated with these forums. I think he has an account here he used to let people know it was created, but it's not by the APOD editors or even by any of us here running the forum. We can't provide support for it.
Just call me "geck" because "zilla" is like a last name.

ekaim
Ensign
Posts: 13
Joined: Fri Aug 17, 2012 1:14 am

Re: Bugs? Problems? Report them here!

Postby ekaim » Fri Aug 17, 2012 4:06 pm

Geckzilla, thanks for your reply. I didn't expect anyone in the forum to be able to offer support for this software, but since I learned about the new software from posts on the forum I thought maybe someone here could point me to a site where I could get help with my question.

Is there another part of the forum where I should post my question?

Pnuu

Re: Bugs? Problems? Report them here!

Postby Pnuu » Tue Oct 23, 2012 12:06 pm

In the current implementation of the RSS, the latest entry points to the main APOD page. Once the day changes, the feed gives two new entries, although there really is only one new item. I propose that the RSS would use the date-based URLs for all the items, eg. http://apod.nasa.gov/apod/ap121023.html for today.

Panu


Return to “Starship Asterisk: Handbook”

Who is online

Users browsing this forum: CommonCrawl [Bot] and 1 guest