Resolved: Bugs? Problems?

Introductions, Rules, Announcements, and Feedback
tomkaten
Asternaut
Posts: 1
Joined: Tue Nov 06, 2007 6:08 pm
Location: Romania

Problem accessing site

Post by tomkaten » Tue Nov 06, 2007 6:15 pm

Hi !

I'm not sure if I'm posting this in the right place, but it's the only forum I found that deals with APOD.

I can't access the site anymore ever since I migrated to an ADSL connection. The server just won't reply. I can access every other site on this planet fine, just not APOD. I'm not using any traffic blocking software and no firewall other than the one in Win XP. Any suggestions would be greatly appreciated, since I'm really addicted to this site and its amazing pictures.

I can provide more details should you need any. Thanks a lot !
Join the army, see the world, meet interesting, exciting people, and kill them.

hermanbubbert
Asternaut
Posts: 2
Joined: Mon Oct 08, 2007 6:02 pm

Post by hermanbubbert » Fri Nov 09, 2007 4:13 pm

The APOD site appears to be down. It's not your setup; it's their server.

makc
Commodore
Posts: 2019
Joined: Tue Oct 12, 2004 5:25 pm

Resolved problems, bugs etc

Post by makc » Mon Nov 03, 2008 7:39 pm

why all NSL threads were killed?

Note added by Nereid (10 Nov): This thread contains 'bug reports' whose triggers have been resolved, leaving the Bug? Problems? Report them here! thread for new bugs (etc). This post, by makc, is the first such report, which is why it's at the head of this thread.

Nereid
Intrepidus Dux Emeritus
Posts: 832
Joined: Fri Sep 29, 2006 2:01 am

Re: Bugs? Problems? Report them here!

Post by Nereid » Mon Nov 03, 2008 11:35 pm

makc wrote:why all NSL threads were killed?
The Night Sky Live project has entered a new phase, and the material in the posts in the various NSL sections/threads is now of just historical interest ... it should be visible to registered users, but is no longer open to new material.

User avatar
Chris Peterson
Abominable Snowman
Posts: 15756
Joined: Wed Jan 31, 2007 11:13 pm
Location: Guffey, Colorado, USA

Re: Bugs? Problems? Report them here!

Post by Chris Peterson » Tue Nov 04, 2008 6:53 pm

I can log in just fine. The problem is, I have to log in every time I access the forum. In fact, even if I'm already logged in, and click on an email link to a forum response, the new tab starts with a login request. This in spite of the fact that I've (repeatedly) checked the box that I want to stay logged in. I don't have cookies blocked, and I can see a nightskylive cookie being set (and retained).

Don't know if this is just me, or a widespread problem. I can live with it, but it's a PITA, having to click through two additional pages any time I want to read or write something.
Chris

*****************************************
Chris L Peterson
Cloudbait Observatory
http://www.cloudbait.com

User avatar
bystander
Apathetic Retiree
Posts: 20617
Joined: Mon Aug 28, 2006 2:06 pm
Location: Oklahoma

Re: Bugs? Problems? Report them here!

Post by bystander » Tue Nov 04, 2008 6:57 pm

Chris Peterson wrote:I can log in just fine. The problem is, I have to log in every time I access the forum. In fact, even if I'm already logged in, and click on an email link to a forum response, the new tab starts with a login request. This in spite of the fact that I've (repeatedly) checked the box that I want to stay logged in. I don't have cookies blocked, and I can see a nightskylive cookie being set (and retained).

Don't know if this is just me, or a widespread problem. I can live with it, but it's a PITA, having to click through two additional pages any time I want to read or write something.
Not just you, I'm having the same problem.

apodman
Teapot Fancier (MIA)
Posts: 1171
Joined: Wed Aug 15, 2007 6:48 pm
Location: 39°N 77°W

Re: Bugs? Problems? Report them here!

Post by apodman » Tue Nov 04, 2008 7:00 pm

Chris Peterson wrote:I can log in just fine. The problem is, I have to log in every time I access the forum. In fact, even if I'm already logged in, and click on an email link to a forum response, the new tab starts with a login request. This in spite of the fact that I've (repeatedly) checked the box that I want to stay logged in. I don't have cookies blocked, and I can see a nightskylive cookie being set (and retained).

Don't know if this is just me, or a widespread problem. I can live with it, but it's a PITA, having to click through two additional pages any time I want to read or write something.
Without checking point-by-point, this sounds like what I'm experiencing, too. Along with various other features that work a little differently with this version of phpBB. The repeated login thing is a nuisance.

User avatar
Chris Peterson
Abominable Snowman
Posts: 15756
Joined: Wed Jan 31, 2007 11:13 pm
Location: Guffey, Colorado, USA

Re: Bugs? Problems? Report them here!

Post by Chris Peterson » Tue Nov 04, 2008 7:20 pm

Chris Peterson wrote:I can log in just fine. The problem is, I have to log in every time I access the forum. In fact, even if I'm already logged in, and click on an email link to a forum response, the new tab starts with a login request. This in spite of the fact that I've (repeatedly) checked the box that I want to stay logged in. I don't have cookies blocked, and I can see a nightskylive cookie being set (and retained).
To follow up...

The ID cookie from the forum was an old one. I deleted all my bb.nightskylive.net cookies and logged in again. Only one cookie is created, named style_cookie and not containing any identifying information. So the problem appears to involve the phpBB configuration, and is outside of user control.
Chris

*****************************************
Chris L Peterson
Cloudbait Observatory
http://www.cloudbait.com

Nereid
Intrepidus Dux Emeritus
Posts: 832
Joined: Fri Sep 29, 2006 2:01 am

Re: Bugs? Problems? Report them here!

Post by Nereid » Tue Nov 04, 2008 7:24 pm

Thanks for posting this bug.

I'll set about addressing it shortly, but I would ask you to please be patient as phpBB3 works quite differently than phpBB2, in many ways.

If anyone reading this has experience with phpBB3, knows what's likely happening, and can suggest how to fix it, please send me a private message.

User avatar
bystander
Apathetic Retiree
Posts: 20617
Joined: Mon Aug 28, 2006 2:06 pm
Location: Oklahoma

APOD: 2008 Nov 04 - Arp 147

Post by bystander » Wed Nov 05, 2008 1:33 pm


Nereid
Intrepidus Dux Emeritus
Posts: 832
Joined: Fri Sep 29, 2006 2:01 am

Re: Bugs? Problems? Report them here!

Post by Nereid » Thu Nov 06, 2008 4:31 pm

Nereid wrote:Thanks for posting this bug.

I'll set about addressing it shortly, but I would ask you to please be patient as phpBB3 works quite differently than phpBB2, in many ways.

If anyone reading this has experience with phpBB3, knows what's likely happening, and can suggest how to fix it, please send me a private message.
Chris, bystander, apodman, and anyone else who is experiencing this problem: please first try clearing the cookies in your browser, and closing and restarting it; it may also be necessary to restart your PC. Please also click on the link, at the bottom of your phpBB screen, "Delete all board cookies". Then try again (you'll have to tick the <Log me on automatically each visit> box again).

I'm trying to determine the extent to which this is at least partly a browser problem, so may I ask what browsers you're having these problems with, and whether there are no such problems with one browser than another?

User avatar
Qev
Ontological Cartographer
Posts: 576
Joined: Wed Mar 08, 2006 8:20 pm

Re: Bugs? Problems? Report them here!

Post by Qev » Thu Nov 06, 2008 7:27 pm

I've followed the steps posted, and the problem still seems to be occurring. I've tried it using Firefox v3.0.3, and Internet Explorer v6.0.2900.2180 (yeah, I know, I'm out of date... :)); both show the same behaviour.
Don't just stand there, get that other dog!

User avatar
Chris Peterson
Abominable Snowman
Posts: 15756
Joined: Wed Jan 31, 2007 11:13 pm
Location: Guffey, Colorado, USA

Re: Bugs? Problems? Report them here!

Post by Chris Peterson » Thu Nov 06, 2008 7:40 pm

Nereid wrote:Chris, bystander, apodman, and anyone else who is experiencing this problem: please first try clearing the cookies in your browser, and closing and restarting it; it may also be necessary to restart your PC. Please also click on the link, at the bottom of your phpBB screen, "Delete all board cookies". Then try again (you'll have to tick the <Log me on automatically each visit> box again).

I'm trying to determine the extent to which this is at least partly a browser problem, so may I ask what browsers you're having these problems with, and whether there are no such problems with one browser than another?
No change. Tried IE6 and FF3, same results. I have some development tools on my system, and I can see that the problem is that no attempt is being made to set a cookie with the id information. Another cookie does get set, so there's nothing blocking bb.nightskylive.net from doing that.

Have you seen this site? It has some suggestions that seem to address exactly this problem.
Chris

*****************************************
Chris L Peterson
Cloudbait Observatory
http://www.cloudbait.com

Nereid
Intrepidus Dux Emeritus
Posts: 832
Joined: Fri Sep 29, 2006 2:01 am

Re: Bugs? Problems? Report them here!

Post by Nereid » Thu Nov 06, 2008 8:00 pm

Chris Peterson wrote:
Nereid wrote:Chris, bystander, apodman, and anyone else who is experiencing this problem: please first try clearing the cookies in your browser, and closing and restarting it; it may also be necessary to restart your PC. Please also click on the link, at the bottom of your phpBB screen, "Delete all board cookies". Then try again (you'll have to tick the <Log me on automatically each visit> box again).

I'm trying to determine the extent to which this is at least partly a browser problem, so may I ask what browsers you're having these problems with, and whether there are no such problems with one browser than another?
No change. Tried IE6 and FF3, same results. I have some development tools on my system, and I can see that the problem is that no attempt is being made to set a cookie with the id information. Another cookie does get set, so there's nothing blocking bb.nightskylive.net from doing that.

Have you seen this site? It has some suggestions that seem to address exactly this problem.
Thanks; let's see if applying what's covered there works ...

May I ask others who have been experiencing this problem if this (what's described in the thread Chris links to) described the entirety of your problems? If not, what other difficulties or peculiarities are you experiencing?

User avatar
Chris Peterson
Abominable Snowman
Posts: 15756
Joined: Wed Jan 31, 2007 11:13 pm
Location: Guffey, Colorado, USA

Re: Bugs? Problems? Report them here!

Post by Chris Peterson » Thu Nov 06, 2008 8:45 pm

Nereid wrote:Thanks; let's see if applying what's covered there works ...
If you've made some changes, they aren't doing the trick. Same behavior.

Do you have persistent logins enabled, and those cookie paths all set to bb.nightskylive.net?
Chris

*****************************************
Chris L Peterson
Cloudbait Observatory
http://www.cloudbait.com

Nereid
Intrepidus Dux Emeritus
Posts: 832
Joined: Fri Sep 29, 2006 2:01 am

Re: Bugs? Problems? Report them here!

Post by Nereid » Thu Nov 06, 2008 9:18 pm

Chris Peterson wrote:
Nereid wrote:Thanks; let's see if applying what's covered there works ...
If you've made some changes, they aren't doing the trick. Same behavior.

Do you have persistent logins enabled, and those cookie paths all set to bb.nightskylive.net?
Sorry, I wasn't clear ...

No changes made yet, and unlikely to be made until tomorrow; I'll post here when they're done.

LuluAtHome
Asternaut
Posts: 3
Joined: Thu Nov 06, 2008 8:56 pm

Re: Bugs? Problems? Report them here!

Post by LuluAtHome » Thu Nov 06, 2008 9:30 pm

Hello, Bugmaster!
all the images are so lovely and the site fills me with joy
every day. But why, why, why do you allow the descriptive text
to stretch the width of the browser window? This is a very
simple HTML fix, and would be so much easier to READ.
THANK YOU for all the good stuff though...

Nereid
Intrepidus Dux Emeritus
Posts: 832
Joined: Fri Sep 29, 2006 2:01 am

Re: Bugs? Problems? Report them here!

Post by Nereid » Thu Nov 06, 2008 10:12 pm

Chris Peterson wrote:
Nereid wrote:Thanks; let's see if applying what's covered there works ...
If you've made some changes, they aren't doing the trick. Same behavior.

Do you have persistent logins enabled, and those cookie paths all set to bb.nightskylive.net?
OK, try now ... and let me know if it's still giving you problems.

Also, some people have difficulty with posting, and all too easily posted duplicates; that too has been solved (I trust).

Nereid
Intrepidus Dux Emeritus
Posts: 832
Joined: Fri Sep 29, 2006 2:01 am

Re: Bugs? Problems? Report them here!

Post by Nereid » Thu Nov 06, 2008 10:15 pm

LuluAtHome wrote:Hello, Bugmaster!
all the images are so lovely and the site fills me with joy
every day. But why, why, why do you allow the descriptive text
to stretch the width of the browser window? This is a very
simple HTML fix, and would be so much easier to READ.
THANK YOU for all the good stuff though...
Welcome LuluAtHome! :)

It seems you're talking about the APODs, rather than what's in this forum (APOD Discussions), right?

That's actually an entirely different setup over which I have no control (and neither do any of the other admins or mods here). However, thanks for bringing it to our attention (does anyone else feel this is a problem?); I'll make sure your feedback gets to the right people.

User avatar
Chris Peterson
Abominable Snowman
Posts: 15756
Joined: Wed Jan 31, 2007 11:13 pm
Location: Guffey, Colorado, USA

Re: Bugs? Problems? Report them here!

Post by Chris Peterson » Thu Nov 06, 2008 10:28 pm

Nereid wrote:OK, try now ... and let me know if it's still giving you problems.
That seems to have done the trick. Several additional cookies are being set, and the site now remembers I'm logged in. Thanks for the fix... this is much more convenient.
Chris

*****************************************
Chris L Peterson
Cloudbait Observatory
http://www.cloudbait.com

User avatar
Chris Peterson
Abominable Snowman
Posts: 15756
Joined: Wed Jan 31, 2007 11:13 pm
Location: Guffey, Colorado, USA

Re: Bugs? Problems? Report them here!

Post by Chris Peterson » Thu Nov 06, 2008 10:32 pm

Nereid wrote:That's actually an entirely different setup over which I have no control (and neither do any of the other admins or mods here). However, thanks for bringing it to our attention (does anyone else feel this is a problem?); I'll make sure your feedback gets to the right people.
I wouldn't call it a problem, exactly. But for people who maximize their browser and have a large display, the descriptive text is a little uncomfortable to read (I don't do that, so it doesn't bother me). However, from a design standpoint, I think it would be better if the descriptive text was restricted to a width similar to that of the image itself.
Chris

*****************************************
Chris L Peterson
Cloudbait Observatory
http://www.cloudbait.com

User avatar
Qev
Ontological Cartographer
Posts: 576
Joined: Wed Mar 08, 2006 8:20 pm

Re: Bugs? Problems? Report them here!

Post by Qev » Fri Nov 07, 2008 12:53 am

Nereid wrote:OK, try now ... and let me know if it's still giving you problems.
It's working fine for my browsers now, also. Thanks, Nereid! :)
Don't just stand there, get that other dog!

User avatar
bystander
Apathetic Retiree
Posts: 20617
Joined: Mon Aug 28, 2006 2:06 pm
Location: Oklahoma

Re: Bugs? Problems? Report them here!

Post by bystander » Fri Nov 07, 2008 4:44 am

Chris Peterson wrote:Have you seen this site? It has some suggestions that seem to address exactly this problem.
Nereid wrote:Thanks; let's see if applying what's covered there works ...
Chris Peterson wrote:Do you have persistent logins enabled, and those cookie paths all set to bb.nightskylive.net?
Nereid wrote:OK, try now ... and let me know if it's still giving you problems.
Everything seems to be working well. Good work and thanks, Nereid. Thanks to you, too, Chris, for your research and suggestions.

LuluAtHome
Asternaut
Posts: 3
Joined: Thu Nov 06, 2008 8:56 pm

Re: Bugs? Problems? Report them here!

Post by LuluAtHome » Fri Nov 07, 2008 5:50 pm

Nereid wrote:
LuluAtHome wrote:Hello, Bugmaster!.........
Welcome LuluAtHome! :)

It seems you're talking about the APODs, rather than what's in this forum (APOD Discussions), right?
.......
Hi Nereid,
thanks for answering: For YEARS I have waited for APOD to turn their gaze down from
the heavens and glance at their own website's design. The endless sprawling style they
use for text under huge photos was always hard to read, but now I have MS; both my
ability to read and my patience are much more limited...

I thought "APOD Discussions / Bugs" was the place for me to rant, so I am especially
grateful you took the time to reply to my tantrum. Very gracious of you, well done!
--L

Nereid
Intrepidus Dux Emeritus
Posts: 832
Joined: Fri Sep 29, 2006 2:01 am

Resolved problems, bugs etc

Post by Nereid » Mon Nov 10, 2008 2:14 pm

This thread contains 'bug reports' whose triggers have been resolved, leaving the Bug? Problems? Report them here! thread for new bugs (etc).